Dear All ECorp Customers:

In order to offer you better service and also enhanced security for your protection in accordance with the government guidelines, ECorp also known as Business Online Banking is being upgraded in November, 2014. Prior to this upgrade, please evaluate your workstations and upgrade your workstations as seen below.

Deadline for Workstation Requirements:

Please be informed that your workstations must be upgraded by October 31, 2014 to prevent any issues.

ECorp – Business Online Banking Certified Browsers and System Requirements

Workstation Requirements as of November 1, 2014

Operating System
Certified Supported Not Supported
Windows 7
Windows 8
Windows 8.1
Windows Vista
Mac OS 10.7
Mac OS 10.8
Mac OS 10.9
Windows XP
Mac OS 10.6
Browsers
Certified Supported Not Supported
Internet Explorer 9.0 (32-bit)
Internet Explorer 10.0 (32-bit)
Internet Explorer 11.0 (32-bit)
Internet Explorer 9.0 (64-bit)*
Internet Explorer 10.0 (64-bit)*
Internet Explorer 11.0 (64-bit)
Mozilla Firefox(Current Version)*
Google Chrome(Current Version)*
Apple Safari 6+(Mac OS only)*
Internet Explorer 7.0
Internet Explorer 8.0
Internet Explorer 10.0 ('Metro' mode)*
Internet Explorer 11.0 ('Metro' mode)*
Opera*

* If you are using ECorp ACH service then ACH will not function in this browser.